summaryrefslogtreecommitdiffstats
path: root/requirements.txt
blob: 38646fbb4111fddb2c373a949ed59b429c398681 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
##############################################################################
# NOTE: Any requirements with environment specifiers must be explicitly added
#       to pkg/pip/setup_pip.py (in extras_require), otherwise they will be
#       ignored when building a PIP Wheel.
##############################################################################
blinker==1.4
extras==1.0.0
fixtures==3.0.0
Flask==0.12.2
Flask-Gravatar==0.5.0
Flask-Login==0.3.2
Flask-Mail==0.9.1
Flask-Migrate==2.1.1
Flask-Principal==0.4.0
Flask-SQLAlchemy==2.3.2
Flask-WTF==0.14.2
html5lib==1.0.1
linecache2==1.0.0
passlib==1.7.1
pbr==3.1.1
pycrypto>=2.6.1
pyrsistent==0.14.2
python-mimeparse==1.6.0
pytz==2018.3
simplejson==3.13.2
six>=1.11.0
speaklater==1.3
sqlparse==0.2.4
WTForms==2.1
Flask-Paranoid==0.2.0

################################################################
# Modules specifically requires for Python2.7 or greater version
################################################################
psycopg2>=2.7.4;                python_version >= '2.7'
python-dateutil>=2.7.1;         python_version >= '2.7'
htmlmin==0.1.12;                python_version >= '2.7'
Flask-HTMLmin==1.3.2;           python_version >= '2.7'
SQLAlchemy>=1.2.5;              python_version >= '2.7'
Flask-Security>=3.0.0;          python_version >= '2.7'
sshtunnel>=0.1.3;               python_version >= '2.7'

###############################################################
# Modules specifically required for Python2.7 or lesser version
###############################################################
backports.csv==1.0.5;           python_version <= '2.7'
importlib==1.0.3;               python_version <= '2.7'

###############################################################
# Modules required for Python2.6
###############################################################
psycopg2==2.7.3.2;              python_version < '2.7'
Flask-Script==2.0.5;            python_version < '2.7'
ordereddict;                    python_version < '2.7'
python-dateutil==2.5.0;         python_version < '2.7'
SQLAlchemy==1.0.14;             python_version < '2.7'
Flask-Security==1.7.5;          python_version < '2.7'
Flask-BabelEx==0.9.3;           python_version < '2.7'